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Introduction
Dell Wyse thin clients running Windows 10 IoT Enterprise provide access to applications, files, and network resources. The applications and 
files are made available on machines hosting Citrix Receiver, Microsoft Remote Desktop Connection, VMware Horizon client session, and 
Dell Wyse vWorkspace services.

Other locally installed software permits remote administration of the thin clients and provides local maintenance functions. More add-ons 
are available that support a wide range of specialty peripherals and features for environments that require a secure user interface with 64-
bit Windows compatibility. Your thin client device supports Microsoft Silverlight, Microsoft Lync VDI 2013 plug-in, and Microsoft .Net 
Framework 4.6 or later versions. For more information, see www.microsoft.com.

NOTE: The features mentioned in this guide vary depending on the thin client model at your workplace. For more information on 
the features applicable for your thin client, see the respective Quick Start Guides at support.dell.com/manuals.

 

Technical support
To access technical resources self-service portal, knowledge base articles, software downloads, registration, warranty extensions/ RMAs, 
reference manuals, contact information, and so on, visit www.dell.com/wyse/support.

About this guide
This guide is intended for thin client administrators running Windows 10 IoT Enterprise. It provides information and detailed system 
configurations to help you design and manage a Windows 10 IoT Enterprise environment.

Supported thin clients
The following are the list of thin clients that run on Windows 10 IoT Enterprise:

• Wyse 5070 thin client

• Wyse 7040 thin client

• Latitude 3480 mobile thin client

• Latitude 5280 mobile thin client
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Getting started
This section describes the activities that you can perform to start using your thin client device. You can also find information related to the 
available desktop features. When you boot your thin client device for the first time, the user desktop is displayed by default. You can log in 
to the thin client device as a user or an administrator. An administrator can configure a user account to log on automatically or manually by 
entering the login credentials.

To get started using your thin client device, see:

• Automatic and manual Logon

• Before configuring your thin clients

• Using the Start Menu

• Using the Search Box

• Using Action Center

• Grouping applications into desktops

• Connecting to a printer or an external device

• Power state

 

Automatic and manual login
What you see when a thin client turns on or reboots depends on the administrator’s configuration. After creating a user account, an 
administrator can configure the account to log in automatically or manually with user credentials.

For more information, see Managing Users and Groups with User Accounts.

NOTE: 

• Ensure that you disable the Unified Write Filter (UWF) before you change a password on the thin client, and then enable UWF after 
your change. For more information, see Before configuring your thin clients.

• To change the password, press Ctrl+Alt+Delete, and then click Change a password. However, this feature is not applicable for 
User accounts.

When you start the thin client, you will automatically log in to the user desktop by default.

NOTE: The Windows icon on the taskbar is the start menu button.

To log in as a different user or administrator:

1 Go to Start > User icon > Sign Out to log out from the current desktop.

2 Click anywhere on the lock screen to view the login window.

3 You can view the user accounts list on the screen. Click the preferred user account and then enter the login credentials.

• Administrators—The default user name is Admin and the default case-sensitive password is DellCCCvdi.

• Users—The default user name is User and default case-sensitive password is DellCCCvdi.

• Customized User—Log in to your thin client by entering the user credentials which you have set for the customized user 
account.

2
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If automatic login is not enabled, the login window displays when you boot the thin client device. You can log in using the options mentioned 
in step 2 and step 3.

Before configuring your thin clients
Unified Write Filter Utility and NetXClean Utility are meant to protect your thin clients. If you want to retain certain profile configurations 
such as printers, monitors and other peripherals, you can configure NetXClean to refrain from cleaning up explicitly declared profiles. These 
utilities also prevent undesired flash memory writes, and clean-up extraneous information from being stored on the local disk.

However, there are instances where administrators can retain the changed configurations after you log out and restart the thin client.

NOTE: To configure and manage multiple thin clients, see Dell Cloud Client Computing.

Using your desktop
The administrator set configurations are displayed when you log in to the thin client at the first instance.

If you log in as an administrator, the Administrator Desktop is displayed. The thin client administrator desktop typically consists of the 
following:

• Admin Taskbar—It includes,

– The Start Menu button

– The Search box

– Quick Launch Bar icons

– Task View

– Notification area located on the right of the taskbar

NOTE: On the right of the taskbar, click the Notifications icon to open the Action Center window. For more information about 
the Action Center, see Using Action Center.

• Standard Desktop Icons—It includes

– Citrix Receiver

– Dell Thin Client Application

– Ericom Connect WebConnect Client

– Internet Explorer

– PowerTerm Terminal Emulation

– Remote Desktop Connection

– VMware Horizon Client

– vWorkspace

– Dell Wyse WF Disable

– Dell Wyse WF Enable

In addition to the Standard Desktop icons, an extended set of resources for configuring user preference settings and system administration 
is included in the administrator control panel. To open control panel, go to Start > Control Panel. For more information, see Administrative 
features.
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Using the Start Menu
The Start Menu helps you to access all programs, folders, and settings on your thin client. It contains a list of applications that are installed 
on your thin client. To open the Start Menu, do the following:

1 Log in as an administrator.

2 Click the Start Menu button.

NOTE: You can also open the Start Menu by pressing the Windows logo key on your keyboard.

3 From the Start Menu, you can use the following options to navigate through the available applications or configure the settings:

• Settings—Use this option to open the Settings window, and configure common Windows settings. The available settings are:

– System—To configure the display, notifications, applications, and power settings

– Devices—To configure the bluetooth, printer, camera, and other peripheral settings

– Network and Internet—To configure the Wi-Fi, airplane mode, Ethernet, and VPN settings

– Personalization—To configure the background, lock screen, and colors settings

– Accounts—To configure your account settings

– Time and Language—To configure the speech, region, and date settings

– Ease of Access—To configure the narrator, magnifier, and high contrast settings

– Privacy—To configure the location and camera settings

– Update and Security—To configure the Windows update settings

• Power—You can sleep, restart, or turn off your thin client. For more information, see Power State.

• List of applications—Click the Start Menu button to view full list of your applications and programs.

NOTE: On the Start Menu, you can view the list of frequently used applications under Most Used.

Using the search box
Use the search box on the taskbar to look for applications, files, or settings.

To use the search box:

1 Type what you are searching for in the search box on the taskbar.

You can find results for files, applications, or settings across your thin client. The suggestions and results related to your searched item 
are displayed in the Home window.

2 Click the result to open the application or file you searched for.

NOTE: To search for a particular file on your thin client, apply any of the following filters available in the lower pane of the Home 
window, and then search for your desired file:

• Applications filter

• Settings filter

• Documents filter

• Folders filter

• Photos filter

• Videos filter

• Musics filter
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Grouping Applications into Desktops
Create virtual desktops, to group your applications together. In the taskbar, click the Task View icon, and then in the New Desktop, open 
the applications you need.

To move applications between virtual desktops, click Task View, and then drag the application you want from one desktop to another.

Using Action Center
Action center displays important notifications from Windows and your applications on the taskbar, along with quick actions, which get you 
to your most-used settings and applications instantly.

To view your notifications and quick actions, click the Action Center icon on the taskbar. You can also press Windows logo key+A.

• Notifications at a glance—When a notification appears on your desktop or when you view it in Action Center, expand it to read more 
or take action without having to open the related application. You can also clear the notification by selecting and dragging it off the 
screen to the right, or by clicking the Close button.

• Quick Action icons—Quick Action icons allow you to access All Settings and applications that you use often, such as Bluetooth to 
VPN. Select the Expand option to see the settings and applications such as location, the quiet hours, brightness, bluetooth, VPN, the 
battery saver, project, and connect.

The following are the Quick Action options in the Action Center:

– Tablet Mode—Tablet mode makes Windows easier and more intuitive to use with touch on devices such as 2–in–1s, or when you 
do not want to use a keyboard and mouse. To turn on tablet mode, click the Action Center icon on the taskbar, and then select 
Tablet Mode.

– Connect—Use this option to connect to your wireless and bluetooth devices.

– All Settings—Use this option to configure windows settings. For more information, see Using the Start Menu.

– Airplane mode—Use this option to turn off the wireless transmission functions on your device and enable Airplane mode.

Connecting to a printer or an external device
You can connect USB interfaced printers or a USB-to-parallel adapter interfaced printer to your thin client device using a USB port. Follow 
your printer's USB installation instructions before connecting to a USB port.

To connect to the printer, add the printer to the thin client device by using the Add Printer wizard. For more information, see Adding 
printers.

If you want to connect to an external device, add the device to the thin client device. For more information, see Adding devices.

Connecting to monitor
Based on the thin client model, you can connect to an external monitor using the following ports:

• HDMI port

• VGA port

• DisplayPort

• DVI port

• DVI-D port

• Type-C port

10 Getting started



For more information about configuring a dual monitor display, see Configuring dual monitor display.

Power state
You can change the power state options of the thin client device by following the steps mentioned here:

1 On the taskbar, click the Start Menu button.

2 Click Power on the start menu, and select any of the options:

• Sleep—This mode uses little power, your thin client device starts up faster.

• Shut down—Preferred for closing all your open programs, and to shut down your operating system.

• Restart—The thin client device is turned off and turned on instantly.

To use the power state options press ALT+F4, and then select your preferred option from the drop-down list.

NOTE: If automatic login is enabled, the thin client immediately logs in to the default user desktop.
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Accessible applications
When you log in to your thin client as an administrator or a user, the Windows desktop displays certain extended features in the Start 
menu.

You can perform the following tasks:

• Browse the Internet with Internet Explorer

• Use the Dell Thin Client Application

• Configure Citrix Receiver Session Services

• Configure Remote Desktop Connection Session Services

• Use VMware Horizon Client to connect to a Virtual Desktop

• Use Ericom PowerTerm Terminal Emulation

• Use Ericom Connect-WebConnect Client

• Configure a vWorkspace Connection

• Microsoft Lync Vdi 2013 plug-in

• Adobe Flash Player

• Windows Media Player

NOTE: Keyboard Caps Lock Indicator Application—Dell Keyboard driver software (KM632) software provides the Caps Lock 
status indication on the desktop. After you log in to your thin client, when you press the Caps Lock key to enable the Caps 
Lock feature, the lock symbol is displayed on the desktop. If you press the Caps Lock key again to disable the Caps Lock feature, 
the unlock symbol is displayed on the desktop.

 

Browsing the internet with Internet Explorer 11
To open Internet Explorer 11, do either of the following:

• Go to Start > Windows Accessories > Internet Explorer.

• Double-click the Internet Explorer icon on the desktop.

NOTE: 

• To limit writing to the disk, Internet Explorer settings are set at the factory. These settings prevent the usage of limited amount of 
disk space available, and you should not modify these settings.

• The protected mode status of the Internet Explorer is Off as the User Access Control (UAC) is enabled by default. However, UAC 
notifies that you require administrator-level permission before changes are made to your client. The Unified Write Filter (UWF) in 
the build continues to protect your system. For more information, see Before configuring your thin clients.

• Internet Explorer cache settings are 100 MB. Temporary internet files, cache, history locations are set to drive C instead of drive Z 
to support Internet Explorer 11 completely.

Using the Dell Thin Client Application
Use the Dell Thin Client Application to view the general information about the thin client device, custom fields, RAM disk, auto login, system 
shortcuts, and support information.

To access the Dell Thin Client Application page, go to Start > Dell Thin Client Application.
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You can also access the Dell Thin Client Application by clicking the Dell Thin Client Application icon on the desktop.

In the left navigation bar, click the following tabs:

• Client Information—Displays the following thin client device information:

– Under the Product Info category, the following attributes are listed:

◦ Product Name

◦ Product ID

◦ Model Name

◦ Product Version

◦ Windows Embedded Version

◦ Manufacturer

◦ Hardware Rev

◦ Operating system Name

◦ Serial Number

◦ Website

◦ Localized Language

◦ Product Activation Status

– Under the CPU category, the following attributes are listed:

◦ Name

◦ Speed

◦ Address Width

◦ Data Width

– Under the Memory/Storage category, the following attributes are listed:

◦ RAM Memory

◦ Flash

◦ System Partition

– Under the BIOS category, the following attributes are listed:

◦ Version

◦ Manufacturer

– Under the Network category, the following attribute is listed:

◦ MAC (IP Address)

– Under the User category, the following attributes are listed:

◦ User

◦ Domain

• QFE—Displays the list of Microsoft QFEs (previously known as hot fixes) applied to the thin client device.

• Installed Products—Displays the list of applications that are installed on the thin client device.

• WDM Packages—Displays the list of WDM Packages that are applied to the thin client. For more information, see WDM software for 
Remote Administration.

• Copyrights/Patents—Displays copyrights and patents information.

When you log in as an administrator, you can view the tabs such as Custom Fields, RAM disk, Auto Logon, System Shortcuts, and About 
and Support on the Dell Thin Client Application page.

Energy Star logo (an electronic logo) for the Energy Star compliance is also displayed on the Dell Thin Client Application page.
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For more information, see Notable features. In the About and Support tab, you can view the information related to the application version, 
support directory, export support data, and HTML view.

NOTE: The information shown in the dialog box varies for different thin client devices and software releases.

When you log in as a user, only few tabs such as Client Information, QFE, Installed Products, WDM Packages, Copyrights/Patents, 
and About and Support are displayed.

Configuring Citrix receiver session services
Citrix Receiver is a server-based computing technology that separates the logic of an application from its user interface. The Citrix 
Receiver client software installed on the thin client device allows you to interact with the application GUI, while all the application processes 
run on the server.

Citrix Receiver session services are available on the network using Windows Server 2008 or Windows Server 2012 with Terminal Services 
and one of the following installed:

• XenDesktop 7.5

• XenDesktop 7.6

• XenDesktop 7.8

• XenDesktop 7.9

• XenDesktop 7.11

NOTE: 

If you use a Windows Server 2003, Windows Server 2008, or Citrix XenApp 5.0 with Windows Server 2008, a Terminal Services Client 
Access License (TSCAL) server must also be accessible on the network. The server grants a temporary license, which expires after 
120 days. After the temporary license expires, purchase and install the TSCALs on the server. You cannot establish a connection 
without a temporary or permanent license.

To configure a Citrix Receiver session, do the following:

1 Log in as an administrator.

2 Access the Citrix Server using one of the following options:

• From the Start Menu, click Citrix Receiver.

• Double-click the Citrix Receiver icon on the desktop.

After you log in to the Citrix server, the Add Account window is displayed.

3 In the Add Account window, enter the server IP address.

4 Click Next.

• For secure connections, enter Fully Qualified Domain Name (FQDN).

• For non-secure connections, enter the IP address.

5 Enter the user credentials, and click Log on.

You can add an account by providing the IP address, and you can view the details of the Citrix Receiver.

6 Click Yes, and then click Next.

The virtual desktop of the Citrix receiver is displayed.

7 In the virtual desktop window, go to Add Apps (+) > All Applications.

You can select or clear the application check box. The selected applications are displayed on the virtual desktop.

8 On the virtual desktop, click Settings to refresh, add or delete server account, and log off.
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Configuring remote desktop connection session 
services
Remote desktop connection is a network protocol that provides a graphical interface to connect another computer over a network 
connection.

NOTE: If you use a Windows Server 2003, Windows Server 2008, or Citrix XenApp 5.0 with Windows Server 2008, a Terminal 
Services Client Access License (TSCAL) server must also be accessible on the network. The server grants a temporary license, 
which expires after 120 days. After the temporary license expires, purchase and install the TSCALs on the server. You cannot 
establish a connection without a temporary or permanent license.

To configure a remote desktop connection:

1 Log in as a user or an administrator.

2 From the Start menu, click Remote Desktop Connection, or double-click the Remote Desktop Connection icon on the desktop.

The Remote Desktop Connection window is displayed.

3 In the Computer box, enter the computer or the domain name.

4 For advanced configuration options, click Show Options.

a In the General tab, you can enter the login credentials, edit or open an existing RDP connection, or save a new RDP connection 
file.

b In the Display tab, manage the display and the color quality of your remote desktop.

• Move the slider to increase or decrease the size of your remote desktop. To use full screen, move the slider all the way to the 
right.

• Select the color quality of your preference for your remote desktop from the drop-down list.

• Select or clear the Display the connection bar when I use the full screen check box to display or hide the connection bar in 
full screen mode.

c In the Local Resources tab configure audio, keyboard, or local devices and resources for your remote desktop.

• In the Remote audio section, click Settings for advanced audio settings options.

• In the Keyboard section, choose when and where to apply keyboard combinations.

• In the Local devices and resources section, select devices and resources that you want to use in your remote session. Click 
More for more options.

d In the Experience tab optimize the performance of your remote session based on the connection quality.

NOTE: 

If the Unified Write Filter cache is full, you can disable the Bitmap caching in the Experience tab after clicking Show Options 
in the window.

e In the Advanced tab, select the action to be taken when the server authentication fails and configure settings for connection 
through Remote Gateway.

5 Click Connect.

6 To connect to the remote session, enter the login credentials in the Security dialog box.

The remote desktop is displayed with the connection bar on the top if you select the Display the connection bar.

Using VMware Horizon Client to connect to virtual 
desktop
VMware Horizon Client is a locally installed software application that communicates between View Connection Server and thin client 
operating system. It provides access to centrally hosted virtual desktops from your thin clients.
VMware session services can be made available on the network after you install the VMware Horizon 6. It provides virtualized or hosted 
desktops and applications through a single platform to end users.
To connect to a virtual desktop, use the VMware Horizon Client window.
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To open and use the VMware Horizon Client window:

1 Log in as a user or an administrator.

2 Access the VMware Horizon Client window using one of the following options:

• From the Start Menu, click VMware > VMware Horizon Client.

• Double-click the VMware Horizon Client icon on the desktop.

The VMware Horizon Client window is displayed.

3 In the VMware Horizon Client window, use the following guidelines:

a To add a new server connection, either click the New Server option or double-click the Add Server icon in the VMware Horizon 
Client window.

The VMware Horizon Client dialog box is displayed.

b In the VMware Horizon Client dialog box, type a host name or an IP address of a VMware Horizon Connection Server in the 
connection server box.

c Click Connect.
d In the Login dialog box, enter the user name and login password in the respective boxes.
e From the Domain drop-down list, select the domain where the server is located.
f Click Login.

The VMware Horizon Client connects to the selected desktop. After connection is established, the list of published desktops is 
displayed.

g Right-click the particular application or the desktop icon, and then click Launch to connect to that application or desktop.

For more information on VMware Horizon Client, see www.vmware.com.

NOTE: 

Certificate checking mode—Certificate checking mode determines how the client proceeds when the client cannot verify that 
your connection to the server is secure. Dell recommends that you do not change this setting unless instructed by your system 
administrator.

To access the certificate checking mode, click the icon on the upper-right corner of the window, and then click Configure SSL 
from the drop-down list. In the VMware Horizon Client SSL configuration dialog box, select from any of the following options 
based on your requirements:

• Never connect to untrusted servers

• Warn before connecting to untrusted servers

• Do not verify server identify certificates

Configuring vWorkspace connection
vWorkspace is a concept in which the desktop environment of a computer is separated from the physical computer and hosted as a virtual 
workspace on multiple environments, such as a virtual desktop infrastructure (VDI), terminal servers, and/or blade PCs running in a data 
center.

Workspace virtualization helps group and deliver a list of applications or desktops together as a single complete virtual workspace. It 
isolates and centralizes an entire computing workspace. vWorkspace provides flexible, location, and platform independent access by 
delivering virtual workspace from multiple virtualization platforms.

To configure a vWorkspace connection:

1 Log in as a user or an administrator.

2 Go to Start > Dell Wyse vWorkspace, or double-click the vWorkspace icon on the desktop.

The vWorkspace window is displayed.

3 In the vWorkspace window, enter the vWorkspace server IP, or your registered email address or website address.

4 Press Enter.

5 To retrieve your connector configuration from vWorkspace server, provide the username, password, and the domain credentials.

6 Select the Save Credentials (encrypted) check box if you want to save your login credentials.
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7 Select your preferred vWorkspace farm location from the following options:

• Inside Office

• Outside Office

8 Click Connect.

9 To connect to the vWorkspace farm, enter the following credentials in the Login Credentials dialog box:

• Username

• Password

• Domain

The vWorkspace Farm screen is displayed.

For more information about managing your vWorkspace connection, go to support.quest.com.

Configuring vWorkspace Farm
After you log in to the vWorkspace Farm by using the login credentials, the vWorkspace Farm page is displayed. Use this page to configure 
the vWorkspace Farm.

1 Click vWorkspace Farm to view the configuration options available.

If you are successfully connected to the vWorkspace Farm, then the status of the connection is displayed in green color.

2 Click the Settings icon to configure your vWorkspace Farm settings.

a Select the Automatically connect to this configuration on startup check box to allow auto-connect to the specified 
configuration upon startup.

b From the drop-down list, select your location where you want to deploy the vWorkspace Farm. The available options are:

• Always prompt for location

• Use Location Inside Office

• Use Location Outside Office

c Under the Display settings section, the following options can be configured.

• From the Screen resolution drop-down list, select your preferred screen resolution for your vWorkspace session.

• Select the following check boxes as per your requirements:

– Use all my monitors for the remote session

– Display connection bar

– Pin connection bar

d Under the Device settings section, the following options can be configured.

• Select the following check boxes as per your requirements:

– Play audio

– Use USB devices

– Use microphone

• Click More Devices to select additional devices and resources on your computer that you want to use in your remote 
session.

3 Click OK to save your settings.

4 Click the Delete icon, if you want to delete the configured vWorkspace Farm.

5 Click the Info icon to view the Name, Type, and Timestamp of your vWorkspace Farm.

The applications available on your vWorkspace Farm are listed in the My Applications area.

Additional configuration icons are displayed in the upper pane of the vWorkspace page.

1 Click the Log Off icon, if you want to log out from the vWorkspace Farm.

2 Click the + icon to add a new vWorkspace Farm.
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3 Click the Refresh icon to refresh the application set.

4 Click the Change Password icon, if you want to change the password for your vWorkspace Farm.

5 Click the Options icon to access the following options:

• Search (Ctrl+F)

• Status Bar

• Always on top

• Hide when minimized

• About

Using Ericom Connect and WebConnect client
Ericom Connect and WebConnect client provides you with remote access to Windows desktops and applications from any compatible 
phone or tablet. It is dedicated for managed broker access. Ericom Connect and PowerTerm WebConnect connections use the Secure 
Gateway as the address. You can access the Ericom Connect-WebConnect client either as a stand-alone application or on a network.
To access the Ericom Connect and WebConnect client as a stand-alone application:

1 Log in as a user or an administrator.

2 Go to Start > Ericom Connect-WebConnect client > Ericom Connect-WebConnect client or double-click the Ericom Connect-
WebConnect client icon on the desktop.

The Ericom AccessPad login window is displayed.

3 In the Ericom AccessPad login window, enter your credentials, and click Login.

The DELL – Ericom Application Zone window is displayed.

NOTE: By default, the Ericom AccessPad login window is displayed. To set the UI to your preferred language, click the 
Globe icon in the lower-right corner of the window, and select your preferred language from the drop-down list.

4 In the DELL – Ericom Application Zone window, published applications such as the Blaze demo server, RDP demo server, the 
Ericom server, and Paint are displayed.

Double-click any of the applications to access them.

You can also add your own applications from the server site.

5 To create a shortcut on your desktop, click Options > Create a shortcut on Desktop in the DELL – Ericom Application Zone window.

6 To log out, click File > Logout in the DELL- Ericom Application Zone window.

To access the Ericom Connect-WebConnect client through the web browser:

1 Double-click the Internet Explorer icon.

The Internet Explorer web page is displayed.

2 Enter http://serverIP/FQDNWebConnect6.0/AppPortal/Index.asp URL to access the Ericom Power Term Emulation.

The PowerTerm WebConnect Application Portal page is displayed.

3 In the PowerTerm WebConnect Application Portal page, enter the credentials and the domain name.

4 Click Login.

5 After you log in, the published desktops and applications such as the Blaze demo server, RDP demo server, and Paint are displayed.

Double-click any of the applications to access them on a new web page.

You can also add your own applications from the server sit.

6 Click Logout on the left side of the PowerTerm WebConnect Application Portal page to end the Ericom Power Term WebConnect 
session.
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Using Ericom PowerTerm Terminal Emulation
To manage your connections using Ericom PowerTerm Terminal Emulation, do the following:

1 Open the TELNET : PowerTerm InterConnect for thin clients window, using one of the following options mentioned:

• Double-click the PowerTerm Terminal Emulation icon on the desktop.

• From the Start Menu, click Ericom PowerTerm Terminal Emulation > PowerTerm Terminal Emulation.

2 In the Connect dialog box, go to Session Type > TELNET to configure the connection of your choice.

For more information, see Ericom-PowerTerm documentation at Dell Wyse Support Site.

Microsoft Lync VDI 2013 plug-in 
Microsoft Lync VDI 2013 plug-in enables you to experience audio, and video in peer-to-peer calls and conference calls, when using 
Microsoft Lync 2013 in a Virtual Desktop Infrastructure (VDI) environment.

For more information, see www.technet.microsoft.com/en-us/library/jj204683.aspx.

Adobe Flash Player
Adobe Flash Player is the standard for delivering high-impact, and rich web content. The designs, animation, and application user interfaces 
are deployed immediately across all the browsers, and platforms to ensure a rich web experience.

For more information, go to www.adobe.com/software/flash/about/.

Windows Media Player
Windows Media Player provides an intuitive, and easy-to-use interface to play digital media files. It organizes your digital media collection, 
and you can burn CDs of your favorite music, extract music from CDs, sync digital media files to a portable device, and shop for digital 
media content from online stores. For more information, see Windows media player documentation at support.microsoft.com/.
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Administrative features
Admin is a default user profile created for the user who is a member of the administrator group.

To log in as an administrator, see Automatic and manual login. When you log in to your thin client device as an administrator, you can access 
certain notable extended features in the Control Panel.

To access the Control Panel, on the taskbar, click Start Menu > Control Panel.

You can perform the following functions as an administrator:

• Using the administrative tools

• Using TPM and BitLocker

• Using custom fields

• Configuring RAM disk size

• Enabling auto logon

• Using system shortcuts

• Viewing and configuring SCCM components

• Adding devices

• Adding printers

• Configuring dual monitor display.

• Using the sound dialog box.

• Setting region and Language preferences.

• Managing users and groups with user accounts.

• Using Windows Defender.

• Using Windows Defender Advanced Threat Protection (ATP)

• Using the CAD tool.

• Configuring Wyse Device Agent.

• Configuring Citrix HDX RealTime Media Engine.

 

Using Administrative tools
To access the Administrative Tools window, click Start > Control Panel > Administrative Tools.

You can use the Administrative tools window to perform the following tasks:

• Configuring the component services

• Managing the services

4
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Configuring component services
To access and configure the component services, event viewer, and local services use the Component Services console.

1 Log in as an administrator.

2 Go to Start > Control Panel > Administrative Tools.

3 From the Administrative Tools list, select Component Services.

4 In the Component Services console, select component services, event viewer, and local services from the Console Root tree and 
configure.

Viewing the events
To view monitoring and troubleshooting messages from Windows and other programs, use the Event Viewer window.

In the Component Services console, click the Event Viewer icon from the Console Root tree. The summary of all the logs of the events 
that have occurred on your computer is displayed.

Managing the services
To view and manage the services installed on the thin client device, use the Services window. To open the Services window, go to Start > 
Control Panel > Administrative Tool Services.

1 In the Component Services console, click the Services icon from the console tree.

The list of services is displayed.

2 Right-click the service of your choice. You can perform Start, Stop, Pause, Resume, and Restart operations.

You can select the Startup type from the drop-down list:

• Automatic (Delayed Start)

• Automatic

• Manual

• Disabled

NOTE: Ensure that the Write Filter is disabled while managing the services.

Using TPM and BitLocker
A TPM is a microchip designed to provide basic security-related functions, primarily involving encryption keys. BitLocker Drive Encryption 
(BDE) is a full disk encryption feature which is designed to protect data by providing encryption for entire volumes. By default, it uses the 
AES encryption algorithm in CBC mode with a 128 bit key, combined with the Elephant diffuser for additional disk encryption-specific 
security not provided by AES.

Windows 10 IoT Enterprise does not support sysprep on a BitLocker encrypted device. Due to this limitation, you cannot encrypt the 
device, perform a sysprep, and pull the image. To overcome this issue, you must add or modify the TPM related script that handles TPM. 
The device must not be encrypted before sysprep (pull). The device encryption is handled by the post push script that uses the 
TPM_enable.ps1 script located at C:\Windows\setup\tools\. This script must be included before enabling the UWF and after sysprep 

scripts. The PIN used to encrypt the client must be passed to the script as an argument.

To use TPM and BitLocker, do the following:

1 Enable TPM from the BIOS menu.

2 Modify the TPM related part of the script, based on the imaging solution.

3 Uncomment the below lines and update the pin for TPM encryption in the Custom FICore imaging method in C:\Windows\Setup
\CustomSysprep\Modules\Post_CustomSysprep.psm1
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• #cd C:\windows\setup\Tools\TPM\

• #.\TPM_enable.ps1 -pin 1234

4 Uncomment the below lines and update the pin for TPM encryption for SCCM push in C:\Windows\Setup\ConfigMgrSysprep
\Modules\Admin_ConfigMgrSysprep.psm1

• #cd C:\windows\setup\Tools\TPM\

• #.\TPM_enable.ps1 -pin 1234

5 Uncomment the below lines and update the pin for TPM encryption in Non-Factory environment (WDM,WSI, USB Imaging solution) in 
Post_CustomSysprep.psm1
• #cd C:\windows\setup\Tools\TPM\

• #.\TPM_enable.ps1 -pin 1234

If the client is encrypted previously, then do the following to clear the TPM:

1 Enter the BIOS mode.

2 In the TPM configuration, set Change TPM Status to Clear, and then apply the settings.

3 Reboot the device, and enter the BIOS mode again.

4 Set Change TPM Status to Enable and Activate.

Configuring Bluetooth connections
You can use your thin client device with other Bluetooth enabled devices, if it has Bluetooth capability.

NOTE: 

To retain your settings, disable the Unified Write Filter (UWF) and configure NetXClean. For more information, see Before Configuring 
your thin clients.

To configure your thin client for Bluetooth connections:

1 Log in as an administrator.

2 Go to Start > Control Panel > Device Manager.

The Device Manager window is displayed.

3 Expand Bluetooth Radios, and double-click any Bluetooth icon.

For example, double-click Generic Bluetooth Radio to manage the existing Bluetooth device. You can also update the drivers in the 
Update tab.

To add another Bluetooth enabled device to the thin client device, use the Add a Device wizard.

a To open the Devices and Printers window, click the Devices and Printers icon in the Control Panel.
b Click Add a Device.

The Add a Device wizard is displayed.

4 See the device documentation and follow the instructions to turn on Bluetooth on a Bluetooth-enabled device. When the device is 
discovered by the thin client device, select the device.

5 Click Next, and follow the wizard.

Configuring wireless local area network settings
To configure the wireless local area network settings, use Setup a new connection or network window, if wireless support is allowed on 
the thin client device.
To configure the wireless local area network settings, do the following:

1 Log in as an administrator.

2 Go to Start > Control Panel > Network and Sharing Center > Setup a new connection or network. You can also select the Open 
network, and sharing session on the taskbar that appears on the Thin Client Administrator Desktop.

3 In the Setup a new connection or network window, select Manually Connect to Wireless Network.
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4 Click Next.

5 In the dialog box, enter the following:

• Network Name

• Security type

• Encryption type

• Security key

NOTE: Depending on the authentication, enter the security key.

6 Select the Start this connection automatically check box.

7 On the taskbar, select the Open network and sharing session and the name of the network which you entered.

8 Select Connect.

NOTE: You can also view the network available and directly connect from the Open network and sharing session on the 
taskbar of the Thin Client Administrator Desktop.

Using custom fields
To enter configuration strings for use by the Wyse Device Manager (WDM) software, use the Custom Fields dialog box. The configuration 
strings can contain information such as location, user, administrator, and so on.
To enter the information that can be used by the WDM server, do the following:

1 Log in as an administrator.

2 Go to Start > Dell Thin Client Application.

The Dell Thin Client Application window is displayed.

3 On the left navigation bar, click Custom Fields.

4 Enter the custom field information in the custom field boxes, and click Apply.

The custom field information is transferred to the Windows registry which is then available to the WDM server.

CAUTION: 

To permanently save the information, ensure that you disable/enable the Unified Write Filter (UWF). For more information, see 
Before Configuring your thin clients.

NOTE: 

For details about the custom field information, see the WDM documentation at www.dell.com/
support.

Configuring RAM disk size
RAM disk is a volatile memory space used for temporary data storage. It can also be used for temporary storage of other data according to 
administrator discretion. For more information, see Saving files and using local drives

The following items are stored on the RAM disk:

• Browser web page cache

• Browser history

• Browser cookies

• Browser cache

• Temporary internet files

• Print spooling

• User/system temporary files
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To configure the RAM disk size, do the following:

1 Log in as an administrator.

2 Go to Start > Dell Thin Client Application.

The Dell Thin Client Application window is displayed.

3 On the left navigation bar, click RAM Disk.

4 In the RAM disk size field, type or select the RAM disk size you want to configure, and then click Apply.

If you change the size of the RAM disk, you are prompted to restart the system for the changes to take effect.

NOTE: 

To permanently save the information, disable the Unified Write Filter (UWF). For more information, see Before Configuring your 
thin clients.

Enabling auto logon
Automatic logon to a user desktop is enabled by default on the thin client device. To enable or disable auto logon, and to change the default 
user name, password, and domain for a thin client, use the auto logon feature.
To enable/disable auto logon:

1 Log in as an administrator.

2 Go to Start > Dell Thin Client Application.

The Dell Thin Client Application window is displayed.

3 On the left navigation bar, click Auto Logon.

4 To start with the admin logon page, enter Admin in the Default User Name field.

NOTE: By default, the Enable Auto Logon check box is selected.

5 If you want to start with the Logon window with default administrator and user selections and other accounts, clear the Enable Auto 
Logon check box.

CAUTION: To permanently save the information, disable/enable the Unified Write Filter (UWF). For more information, see 
Before Configuring your thin clients.

NOTE: 

If auto login is enabled and you log off from your current desktop, the lock screen is displayed. Click anywhere on the lock screen 
to view the Logon window. Use this window to log in to your preferred administrator or user account.

System shortcuts
The System shortcuts page allows you to directly access some applications, directory, files, and folders without navigating through the 
Start menu or control panel.

1 Log in as an administrator.

2 Go to Start > Dell Thin Client Application.

The Dell Thin Client Application window is displayed.

3 On the left navigation bar, click System Shortcuts.

The following shortcuts are listed in the System Shortcuts area:

• Administrative Tools

• All Control Panel Items

• System Directory

• Program Files

• Temporary Folder
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• My Documents

• Recent Accessed Files

• Dell Thin Client Application Folder

• Application Data Folder

4 Click any of the shortcuts to access the respective folders/files/applications.

Viewing and configuring SCCM components
To view and configure the SCCM components installed on your thin client device, use the Configuration Manager Properties dialog box.

To open the Configuration Manager Properties dialog box:

1 Log in as an administrator.

2 Go to Start > Control Panel > Configuration Manager.

The Configuration Manager Properties dialog box is displayed.

For more information on how to use the Configuration Manager Properties dialog box, see Managing Windows-based Dell Wyse Thin 
Clients using System Center Configuration Manager Administrator’s Guide at support.dell.com/manuals.

System Center Configuration Manager Client LTSB 2016
Microsoft System Center Configuration Manager (SCCM) helps you to empower devices and applications which needs to be productive, 
while maintaining corporate compliance and control. It accomplishes the corporate compliance and control with a unified infrastructure that 
gives a single pane of glass to manage physical, virtual, and mobile clients.

It also provides tools and improvements that makes easier for you to do the jobs. With SP1, it provides integration with Windows Intune to 
manage PCs and mobile devices, both from the cloud and on-premise, from a single administrative console. For more information, see 
Managing Windows-based Dell Wyse Thin Clients using System Center Configuration Manager Administrator’s Guide at support.dell.com/
manuals.

Devices and printers
To add devices and printers, use the Devices and Printers window.

CAUTION: To refrain from cleaning up your settings, disable/enable the Unified Write Filter (UWF) and configure NetXClean. For 
more information, see Before Configuring your thin clients.

To add a device or a printer to the thin client, do the following:

1 Log in as an administrator.

2 Go to Start > Control Panel > Devices and Printers.

The Devices and Printers window is displayed.

Adding printers
To add a printer to the thin client:

1 Click the Devices and Printers icon in Control Panel.

The Devices and Printers window is displayed.

2 To open and use the Add a Printer wizard, click Add a Printer.

The Add a Printer wizard session starts.
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A Dell Open Print Driver is installed on the thin client along with other built-in print drivers. To print full text and graphics to a local 
printer, install the driver provided by the manufacturer according to the instructions.

Printing to network printers from Citrix Receiver, Remote Desktop Connection or VMware Horizon Client applications can be 
achieved through printer drivers on the servers.

Printing to a local printer from Citrix Receiver, Remote Desktop Connection or VMware Horizon Client application using the printer 
drivers of the server produces full text and graphics functionality from the printer. Install the printer driver on the server, and the text 
only driver on the thin client using the following procedure:

a Click Add a local printer, and click Next.
b Click Use an existing port, select the port from the list, and then click Next.
c Select the manufacturer and model of the printer, and click Next.
d Enter a name for the printer and click Next.
e Select Do not share this printer and click Next.
f Select whether to print a test page and click Next.
g Click Finish to complete the installation.

A test page will print after installation if this option was selected.

Adding devices
To add a device to the thin client:

1 Click the Devices and Printers icon in Control Panel and open the Devices and Printers window.

2 To open and use the Add a Device wizard, click Add a Device.

The Add a Device wizard session starts. You can use the wizard to add a device of your choice to the thin client.

Configuring dual monitor display
You can use the Screen Resolution window to configure dual monitor settings on your dual-monitor capable thin client device.
To open the Screen Resolution window, do the following:

1 Log in as an administrator.

2 Go to Start > Control Panel > Display > Change Display Settings.

The Screen Resolution window is displayed. For detailed instructions on how to configure the screen resolution, go to 
www.microsoft.com.

For information about setting up multiple monitors, see the How to Set up Multiple Monitors in Windows 10 at support.dell.com.

Managing audio and audio devices
To manage your audio and audio devices, use the Sound dialog box.
To manage audio and audio devices, log in as an administrator, and open the Sound dialog box.

Using sound dialog box
To manage your audio devices, use the Sound dialog box.
To open the Sound dialog box:

1 Go to Start > Control Panel > Sound.

The Sound dialog box is displayed.

2 Use the following tabs, and configure the sound related settings:

• Playback—Select a playback device and modify the settings.
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• Recording—Select a recording device and modify the settings.

• Sounds—Select an existing or modified sound theme for events in Windows or programs.

• Communications—Click an option to adjust the volume of different sounds when you are using your thin client to place or receive 
telephone calls.

3 Click Apply, and click OK.

NOTE: 

• Dell recommends powered speakers.

• You can also adjust the volume using the Volume icon in the notification area of the taskbar.

Setting region
To select your regional formats including keyboard and the Windows display languages, use the Region dialog box.
To select your regional formats, do the following:

1 Log in as an administrator.

2 Go to Start > Control Panel > Region.

The Region dialog box is displayed.

3 In the Formats tab, select the language, date, and time.

To customize the formats, do the following:

a Click Additional Settings.

The Customize Format window is displayed.

b Customize the settings, and click OK.

4 Click Apply, and then click OK.

5 In the Location tab, select a particular location to display additional information such as news and weather.

6 In the Administrative tab, change the language to be displayed in programs that do not support Unicode, and copy the settings.

Managing user accounts
To manage users and groups, use the User Accounts window.
To open the User Accounts window, do the following:

1 Log in as an administrator.

2 Go to Start > Control Panel > User Accounts.

For more information on using the User Accounts window, see Managing Users and Groups with User Accounts.

Using Windows Defender
To scan your computer and protect against spyware and malware, use the Windows Defender dialog box.
To open the Windows Defender window, do the following:

1 Log in as an administrator.

2 Go to Start > Control Panel > Windows Defender.

The Windows Defender window is displayed. In the Home tab, select a scan option, and click Scan Now.

To configure and manage your thin client device, you can use anti-malware software settings in the Settings tab.
Windows Defender is anti-spyware software that is included with Windows and runs automatically when you turn on your thin client. Using 
anti-spyware software, helps you to protect the device against spyware and other potentially unwanted software. Spyware can be installed 
on your device without your knowledge any time you connect to the internet, and it can infect your computer when you install some 
programs using a CD, DVD, or other removable media. Spyware can also be programmed to run at unexpected times, not just when it is 
installed.

NOTE: Windows Defender updates automatically at 1:00 AM on second Sunday of every month.
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C-A-D tool
The C-A-D tool allows administrators to map the Ctrl+Alt+Del key combination of VDI applications to display the Ctrl+Alt+Del screen of the 
VDI application. If the C-A-D tool is enabled, you can use Ctrl+Alt+Del key combination for all VDI applications.

The following are the mapped keys for different VDI applications supported by C-A-D tool:

• Citrix—Ctrl+F1

• Dell vWorkspace—Ctrl+Alt+End

• RDP—Ctrl+Alt+End

NOTE: The C-A-D tool does not work for Xen Desktop in a Citrix session, but works only for the Citrix Xen applications.

The C-A-D tool is disabled by default in this build. To enable the C-A-D tool, do the following:

1 Log in as an administrator.

2 Disable the Write Filter.

3 Launch Command Prompt in elevated mode.

4 Enter cd c:\windows\system32

5 Run DWKBFilterMon.exe and, reboot.

6 Enable the Write Filter.

Wyse Device Agent
Wyse Device Agent (WDA) is a unified agent for all thin client management solutions. Installing WDA on a thin client makes it manageable 
by Dell Wyse Device Manager (WDM), and Dell Cloud Client Manager (CCM). For more information, see the latest Dell Wyse Device Agent 
Release Notes at support.dell.com/manuals.

Citrix HDX RealTime Media Engine
Citrix HDX RealTime Optimization Pack for Microsoft Lync provides highly scalable solution for delivering real-time audio-video 
conferencing and the VoIP enterprise telephony through Microsoft Lync in the XenDesktop and XenApp environments to users on Linux, 
Mac, and the Windows devices. HDX RealTime Optimization Pack applies your existing Microsoft Lync infrastructure and inter operates 
with other Microsoft Lync endpoints running natively on devices.

For more information, see Citrix documentation.

Windows Defender Advanced Threat Protection
Windows Defender Advanced Threat Protection (ATP) is a new service that helps enterprises to detect, investigate, and respond to 
advanced attacks on their networks.

Windows Defender ATP works with existing Windows security technologies on endpoints, such as Windows Defender, AppLocker, and 
Device Guard. It also works with third-party security solutions, and anti-malware products. For more information, see the Windows 
Defender Advanced Threat Protection documentation at docs.microsoft.com

Viewing and exporting of operating system image 
manifest files 
Manifest file is an xml document which contains metadata about the OS image as part of the thin client. The current and the factory 
manifest files can be compared to find change on the thin client on premise. On the thin clients, the following are the two types of manifest 
file based on the source of data collection:
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Table 1. Manifest files

Manifest 
Source

AboutCpy AutoLogon Custom 
Fields

General 
Info

Installed 
Products

RAMDisk QFE WDM 
Packages

Drivers

Current 
Manifest

Yes Yes Yes Yes Yes Yes Yes Yes No

Factory 
Manifest

No No No No Yes No Yes No Yes

You must compare the InstalledProducts & QFEs columns. InstalledProducts and QFE from current and the factory manifest files can be 
compared to find change on the thin client on premise with respect to installed applications and QFE’s.

NOTE: Installed Product refers to all the installed applications on the thin client.

Viewing and exporting the operating system image current 
manifest information 
1 Log in as an administrator.

2 Go to Start > Dell Thin Client Application > About and Support.

3 Click Export support data.

Data extracted and zipped successfully message is displayed.

4 Click Support Directory.

The DellTCASupportInfo folder is displayed.

The support directory contains the current manifest of the thin client with the folder structure as follows:

Figure 1. Support directory

5 Go to xml folder to view the InstalledProducts and QFE xml files.

Figure 2. xml folder

Viewing the operating system image factory manifest 
information
1 Log in as an administrator.

2 Go to <drive C>\Windows\Setup\Tools.
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3 The BuildContent folder contains the factory manifest of the thin client with the folder structure as follows:

Figure 3. BuildContent folder

• To view the information of the installed products in the factory at the time of shipment, go to Apps > InstalledProducts xml file.

• To view the information of the QFE’s installed in the factory at the time of shipment, go to Qfe > QFE xml file.

Use case scenario—The InstalledProducts and QFE xml files generated through the Thin Client Application (current manifest information 
set) and the xml files present in the <drive C>\Windows\Setup\Tools\BuildContent folder (factory manifest information set) can be 
compared to find the changes with respect to the installed application and QFE’s.

NOTE: The Support Directory and the Build Content data in the Thin Client Application should be shared with the support team 
during troubleshooting.
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Additional administrator utility and settings 
information

This section provides additional information about utilities and settings available for administrators.

• Automatically launched utilities

• Utilities affected by log off, restart, and shut down

• Using the Unified Write Filter

• Understanding the NetXClean utility

• Saving files and using local drives

• Mapping network drives

• Participating in domains

• Using the Net and Tracert utilities

• Managing users and groups with user accounts

• Changing the computer name of a thin client

 

Automatically launched utilities
The following utilities start automatically after you turn on the system, or after you log in to the thin client:

• Unified Write Filter—After you turn on the system, the Unified Write Filter utility starts automatically. The icon in the notification area 
of the taskbar indicates the active or inactive status of the Unified Write Filter. For more information, see Using the Unified Write Filter 
(UWF).

NOTE: While the Dell Wyse Write Filter icons and functionality are currently supported, Dell recommends you to use the UWF 
as described in the Microsoft documentation available at www.microsoft.com, and navigate to the Unified Write Filter 
documentation.

• NetXClean Utility—After you turn on the system, the NetXClean utility starts automatically. NetXClean is a clean-up utility that keeps 
extraneous information from being stored on the local disk. If you want to keep certain profile configurations such as for printers, be 
sure to configure NetXClean to refrain from cleaning up any number of explicitly declared profiles. For more information, see 
Understanding the NetXClean Utility.

• VNC Server—After you log in to your thin client, the Windows VNC Server utility starts automatically. VNC allows a thin client desktop 
to be accessed remotely for administration and support. For more information, see Using Tight VNC to Shadow a thin client.

Utilities affected by log off, restart, and shut down
The following utilities are affected by logging off, restarting, and shutting down the thin client device:

• Unified Write Filter—After you turn on the system, the Unified Write Filter utility starts automatically. Dell recommends you to use the 
UWF as described in the Microsoft documentation. For more information, see www.microsoft.com, and navigate to the Unified Write 
Filter documentation.

• NetXClean Utility—NetXClean is a clean-up utility that keeps extraneous information from being stored on the flash memory. Clean-up 
is triggered automatically on restart, shut-down, or user log-off. If you want to keep certain profile configurations, for example, printers, 

5
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configure the NetXClean to refrain from cleaning up any number of explicitly declared profiles. For more information about NetXClean, 
see Before configuring your thin clients, and Understanding the NetXClean utility.

• Power Management—A Monitor Saver turns off the video signal to the monitor, allowing the monitor to enter a power-saving mode 
after a designated idle time. To access the power settings, go to Start > Control Panel > Power Options.

• Wake-on-LAN—This feature discovers all thin clients connected to your LAN, and enables you to wake them by clicking a button. For 
example, to perform image updates and remote administration functions on devices that have been shut down or are on standby. To 
use this feature, the thin client power must be turned on.

Unified Write Filter
Unified Write Filter (UWF) is a sector-based write filter that protects your storage media. UWF intercepts all write attempts to a protected 
volume and redirects those write attempts to a virtual overlay. UWF intercepts all write attempts to a protected volume and redirects the 
write attempts to a virtual overlay. UWF improves the reliability and stability of your device and reduces the wear on write-sensitive media, 
such as solid-state drives. In UWF, an overlay is a virtual storage space that saves changes made to the underlying protected volumes. Any 
time the file system attempts to modify a protected sector, UWF instead copies the sector from the protected volume to the overlay, and 
then modifies the overlay instead. If an application attempts to read from that sector, UWF returns the data from the overlay instead, so 
that the system maintains the appearance of having written to the volume, while the volume remains unchanged.

CAUTION: Failure to keep the Write Filter turned on (except for regular maintenance or Application/Driver installs or upgrades) 
will prematurely wear out your Flash/SSD storage and invalidate your warranty.

For more information, see the Unified Write Filter documentation at www.microsoft.com.

The following are the default file folders excluded from being filtered by UWF:

• C:\Users\Admin\AppData\LocalLow

• C:\Users\User\AppData\LocalLow

• C:\Program Files\Windows Defender

• C:\Program Files (x86)\Windows Defender

• C:\Windows\WindowsUpdate.log

• C:\Windows\Temp\MpCmdRun.log

• C:\windows\system32\spp

• C:\ProgramData\Microsoft\Windows Defender

• C:\program files\Wyse\WDA\Config

• C:\Users\Public\Documents\Wyse

• C:\Wyse\WCM\ConfigMgmt

• C:\Wyse\WCM

• C:\Wyse\WDA

The following are the default registries excluded from being filtered by UWF:

• HKLM\SYSTEM\CurrentControlSet\Control\WNT\DWCADTool

• HKLM\Software\Wyse\ConfigMgmt

• HKLM\SOFTWARE\Microsoft\Windows Defender

• HKLM\SYSTEM\CurrentControlSet\Control\WNT\UWFSvc

• HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\HomeGroup

• HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList

• HKLM\SYSTEM\WPA

CAUTION: Dell recommends you to enable write filter while using thin clients. It can be disabled only by an administrator while 
making necessary changes. Extended use with write filters disabled can reduce the life of your flash drive. It is a good practice to 
enable write filter to ensure device security.
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Using Unified Write Filter
To configure thin client devices using UWF, do the following:

1 Log in as an administrator.

If automatic login to a user desktop is enabled, log off from the user desktop and log in as an administrator.

2 To disable the Unified Write Filter, double-click the Dell Wyse WF Disable icon on the desktop.

This icon disables the filter and reboots the system.

3 Configure the thin client device as per your requirements.

4 After you configure the thin client device, to enable the Unified Write Filter, double-click the Dell Wyse WF Enable icon on the 
desktop.

This icon enables the filter and reboots the system. Your configurations on the thin client device are now saved, and they persist after 
you reboot the thin client.

After system start-up, the Unified Write Filter (UWF) utility starts automatically.

You can add specific files or folders on a protected volume to a file exclusion list to exclude those files and folders from being filtered by 
UWF. When a file or folder is in the exclusion list for a volume, all writes to that file or folder bypass UWF filtering, and are written directly to 
the protected volume and persist after the device restarts.

You must log in as an administrator to add or remove file or folder exclusions during run time, and you must restart the device for new 
exclusions to take effect.

Running Unified Write Filter command–line options
There are several command lines you can use to control the Unified Write Filter. Command–line arguments cannot be combined.

Use the following guidelines for the command–line option for the Unified Write Filter. You can also use the commands if you open the 
command prompt window with elevated privilege by entering command in the Run box.

Table 2. Running Unified Write Filter command–line options

Command-line options Description

uwfmgr This command-line tool configures and retrieves settings for Unified 
Write Filter (UWF). If there are no command-line options available, 
it displays the command help.

uwfmgr filter enable This command-line enables the Unified Write Filter after the next 
system restart. The Unified Write Filter status icon is green when 
the Unified Write Filter is enabled.

uwfmgr filter disable This command-line option disables the Unified Write Filter after the 
next system restart. The Unified Write Filter status icon remains red 
while disabled.

uwfmgr file commit C: <file_path> This command-line commits changes to a specified file to overlay 
for a Unified Write Filter-protected volume. Administrator-level 
permissions are required to use this command.

The <file> parameter must be fully qualified, including the volume 
and path. uwfmgr.exe uses the volume specified in 
the <file> parameter to determine which volume contains the file 
exclusion list for the file. There is a single space between volume 
name and file_path. For example, to commit a file C:\Program Files
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Command-line options Description

\temp.txt the command would be uwfmgr commit C: 
\Program Files\temp.txt.

uwfmgr file add-exclusion C: <file_or_dir_path> This command-line adds the specified file to the file exclusion list of 
the volume protected by Unified Write Filter. Unified Write Filter 
starts excluding the file from filtering after the next system restart.

For example, to add a registry directory HKLM\SYSTEM\WPA, the 
command is UWFmgr.exe registry add-exclusion HKLM
\SYSTEM\WPA.

uwfmgr file remove-exclusion C: <file_or_dir_path> This command-line removes the specified file from the file exclusion 
list of the volume protected by Unified Write Filter. Unified Write 
Filter stops excluding the file from filtering after the next system 
restart.

uwfmgr overlay get-config This command-line displays configuration settings for the Unified 
Write Filter overlay. Displays information for both the current and 
the next session.

uwfmgr registry /? This command-line displays configuration settings for exclusions of 
registry keys.

NOTE: If you open a command prompt window and enter uwfmgr ? or uwfmgr help, all available commands are displayed. 
For information on a command, use uwfmgr help <command>. For example, for information on the command, volume, enter 
uwfmgr help volume.

CAUTION: 

• Administrators should use file security to prevent unwanted usage of these commands.

• Do not attempt to flush the data to the disk while another flush operation is in progress.

Enabling and disabling the Write Filter using the desktop icons
The Unified Write Filter can also be enabled or disabled using the Write Filter Enable/Disable desktop icons. The icon in the notification area 
of the taskbar indicates the active or inactive status of the Unified Write Filter by the colors green and red respectively.

• Dell Wyse WF Enable Icon (Green)—Double-clicking this icon enables the Unified Write Filter. This utility is similar to running the 
uwfmgr filter enable command-line. However, double-clicking this icon immediately restarts the system and enables the Unified Write 
Filter. The Unified Write Filter status icon in the notification area of the taskbar is green when the Unified Write Filter is enabled.

• Dell Wyse WF Disable Icon(Red)—Double-clicking this icon disables the Unified Write Filter. This utility is similar to running the 
uwfmgr filter disable command-line option. However, double-clicking this icon restarts the system immediately. The Unified Write Filter 
status icon in the notification area of the taskbar remains red if the Unified Write Filter is disabled.

Setting Write Filter controls
To view and manage UWF control settings, use the Unified Write Filter Control dialog box. To open the dialog box, double-click the UWF 
icon in the notification area of the administrator taskbar.

When you configure UWF control settings, some of the fields are unavailable. You can select from the list of available fields during 
configuration.
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The Dell Wyse Unified Write Filter Control dialog box includes the following:

• UWF status

– Current Status—Shows the status of the Unified Write Filter. The status may either be Enabled or Disabled.

– Boot Command—Shows the status of the Boot Command. UWF_ENABLE means that the UWF is enabled for the next session; 
and UWF_DISABLE means that the UWF is disabled for the next session.

– RAM used by UWF—Shows the amount of RAM allocated to the Unified Write Filter in Mega bytes (MB) and Percentage. If 
Current Status is disabled, RAM allocated to UWF is always zero (0).

– Amount of RAM used for UWF Cache—Shows the amount of RAM allocated to the Unified Write Filter cache for the current 
session in Megabytes (MB).

– Warning #1 (%)—Shows the UWF cache percentage value at which a Low Memory warning message is displayed to the user for 
the current session.

– Warning #2 (%)—Shows the UWF cache percentage value at which a Critical Memory warning message is displayed to the user.

• UWF Cache settings

– Amount of RAM to be used for UWF Cache—Shows the amount of RAM that is to be used as the Unified Write Filter cache for 
the next session in MB. This value should be in the range of 256 MB to 2048 MB. There is an extra check to ensure that this value 
does not exceed 50% of Total Available RAM.

• UWF Warning settings

– Warning #1 (%)—Shows the UWF cache percentage value at which a Low Memory warning message is displayed to the user 
(Default value = 80, Minimum value = 50, Maximum value = 80).

– Warning #2 (%)—Shows the UWF cache percentage value at which a Critical Memory warning message is displayed to the user. 
Once the memory level crosses the warning level 2, system automatically restarts. (Default value = 90, Minimum value = 55, 
Maximum value = 90)

• Enable UWF—Allows you to enable the Unified Write Filter and prompts you to restart the thin client device. To save the changes, 
restart the thin client. After the system restarts to enable the Unified Write Filter, the Unified Write Filter status icon in the desktop 
notification area turns green.

• Disable UWF—Allows you to disable the Unified Write Filter and prompts you to restart the thin client device. To save the changes, 
restart the thin client. After disabling the Unified Write Filter, the Unified Write Filter status icon in the desktop notification area turns 
red and the Unified Write Filter remains disabled after the system restarts.

• Defaults—Allows you to reset the UWF Cache Settings area, and the UWF Warning Settings area to their default values.

• File Commit area

– File Path—Allows you to add, remove, and commit files to the underlying media. The system does not restart the thin client device. 
The changes are committed immediately.

NOTE: Delete a file path from the list, if the file is not 
committed.

• Current Session Exclusion List

– File/Directory Path—

Allows you to add and remove a file or directory, to or from the exclusion list for the next session. This retrieves the list of files or 
directories that are written through in the current session and the title of the pane is shown as Current Session Exclusion List. The 
Next Session retrieves the list of files or directories that are written through for the next session and the title of the pane is shown 
as Next Session Exclusion List. The system will not restart the thin client, and the changes are not committed until an administrator 
restarts the thin client device manually.

NetXClean utility
NetXClean is a clean-up utility that keeps extraneous information from being stored on the local disk. When multiple users have logon rights 
to a system, the disk space is used by the profiles stored locally. NetXClean can be used to automatically clean-up directories used for 
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temporary caching of information. clean-up is triggered on either service startup or user logoff. It does the clean-up invisibly to the user 
and is completely configurable.

NetXClean is a Windows utility built to run as a service. It is a standalone utility that uses a configuration file to determine which directories 
and files to purge, and which profiles to not purge. The utility can be configured to:

• Delete any number of directories and their contents

• Delete just the contents of any number of directories

• Delete any number of files declared explicitly

• Delete any number of files matching wild-character file names

• Refrain from cleaning up any of the profiles

• Refrain from cleaning up any number of explicitly declared profiles

• Refrain from cleaning up any number of the most recently used profiles

• Perform the directory clean-up on service start event, user logoff event, or both events.

• Perform the file clean-up on service start event, user logoff event, or both events.

• Perform the profile clean-up on service start event, user logoff event, or both events.

NetXClean does not clean-up the following directories or any parent to these directories:

• Windows directory

• Windows System directory

• The current directory where the service is installed in

NetXClean does not delete the following profiles:

• Administrator

• skinnynt

• totalcontrol

• Default_User

• Default_user

• The profile of the last user to logon

NOTE: 

• NetXClean purge selections are made by the manufacturer and should not be changed without manufacturer supervision.

• NetXClean Utility does not have any dependency on Unified Write Filter (UWF).

NetXClean Utility work flow across multiple user profiles
NetXClean Utility helps you to clean-up user profiles when you have multiple user profiles configured on your system. This is applicable in 
scenarios where you log in and log off from your user profiles. A typical user scenario is as follows:

1 Log in as an administrator.

2 In netxclean.ini, specify the profile-specific values which you want the NetXClean Utility to perform.

These values are considered by NetXClean Utility after you log off and log in to your user profiles.

If you restart or perform a hard reboot of your system, the profile-specific values are not considered because the NetXClean Utility 
feature on user profiles is not applicable across reboots.

For more information, see the Dell Knowledge Base.

36 Additional administrator utility and settings information

HTTP://WWW.DELL.COM/SUPPORT/ARTICLE/US/EN/04/SLN291067/DELL-WYSE-WINDOWS-XPE--WES--WES7--WE8S---NETXCLEAN?LANG=EN


Saving files and using local drives
Thin clients use an embedded operating system with a fixed amount of disk space. Dell recommends you to save files that you want to keep 
on a server rather than on a thin client.

CAUTION: Be careful of application settings that write to the drive C, which resides in disk space. By default, these applications 
write cache files to the drive C on the local system. If you must write to a local drive, change the application settings to use the 
drive Z. The default configuration settings mentioned in Managing Users and Groups with User Accounts minimize writing to the 
drive C for factory-installed applications.

drive Z

drive Z is the on-board volatile memory (Dell Wyse RAM Disk) of the thin client. It is recommended that you do not use this drive to save 
data that you want to retain.

For information about using the Z drive with roaming profiles, see Participating in Domains.

drive C

Drive C is the on-board non-volatile flash memory. Dell recommends that you avoid writing to drive C. Writing to drive C reduces the free 
disk space. If the free disk space on drive C is reduced under 3 MB, the thin client will become unstable.

NOTE: Dell recommends that 3 MB of disk space is left unused. If the free disk space is reduced to 2 MB, the thin client image 
will be irreparably damaged and it will be necessary for you to contact an authorized service center to repair the thin client.

Enabling the Unified Write Filter protects the disk from damage and presents an error message if the cache is overwritten. However, if this 
message occurs you will be unable to flush files of the Unified Write Filter cache and any thin client configuration changes still in cache is 
lost. Items that are written to the Unified Write Filter cache or directly to the disk if the Unified Write Filter is disabled during normal 
operations include:

• Favorites

• Created connections

• Delete/edit connections

For information on the role of NetXClean in keeping the disk space clean, see Understanding the NetXClean Utility.

Mapping network drives
Administrators can map network drives. However, to retain the mappings after the thin client device is restarted, do the following:

1 Log in as an administrator.

2 On the taskbar, click the search icon, and then enter This PC.

This PC desktop application is displayed in the Best Match area on the result page.

3 Right-click This PC, and then click Map network drive.

The Map Network Drive dialog box is displayed.

4 Select the drive letter from the Drive drop-down list, and type or browse for the folder you want to connect.

5 Select the Reconnect at logon check box.

6 Empty the files of the Unified Write Filter cache during the current system session.

Since a user login account cannot flush the files of the Unified Write Filter cache, the settings can be retained by logging off from the 
user account, and logging in using an administrator account. Also, remove the files of the cache. Do not shut down, or restart the 
system.

NOTE: A remote home directory can also be assigned by using a user manager utility or by other means known to an 
administrator.

7 Click Finish to complete the network drive mapping.

Additional administrator utility and settings information 37



Participating in domains
You can participate in domains by joining the thin client device to a domain or by using roaming profiles.
To join a domain, do the following:

1 Log in as an administrator.

2 Go to Start > Control Panel > System.

The System window is displayed.

3 In the Computer name, domain and workgroup settings section, click Change Settings.

The System Properties dialog box is displayed.

4 Click Change option to change the domain or workgroup.

a Click Domain.

The Computer Name/Domain Changes dialog box is displayed.

b Enter the domain of your choice.
c Click OK.

5 To join a thin client device to a domain, click Network ID.

The Join a Domain or Workgroup wizard is displayed. On the first page of the wizard, select the option that describes your network.

• Business Network—Click this option if your thin client is a part of business network and you use it to connect to other clients at 
work.

1 Click Next.

2 Select the option according to your company’s network availability on a domain.

If you select the option Network with a domain, then enter the following information:

– User name

– Password

– Domain name

If you select the option Network without a domain, then enter Workgroup, and then click Next.

NOTE: You can click Next even if you do not know the workgroup name.

3 To apply the changes, you must restart the computer. Click Finish.

NOTE: Before restarting your computer, save any open files and close all 
programs.

• Home Network—Click this option if your thin client is a home client and it is not a part of a business network. To apply the 
changes, you must restart the computer. Click Finish.

CAUTION: Exercise caution when joining the thin client device to a domain as the profile downloaded at logon could 
overflow the cache or flash memory.

When joining the thin client device to a domain, the Unified Write Filter should be disabled so that the domain information can be 
permanently stored on the thin client device. The Unified Write Filter should remain disabled through the next restart as information is 
written to the thin client on the restart after joining the domain. This UWF is important when joining an Active Directory domain. For 
details on disabling and enabling the Unified Write Filter, see Before Configuring your Thin Client.

To make the domain changes permanent, complete the following:

a Disable the Unified Write Filter.
b Join the domain.
c Restart the thin client.
d Enable the Unified Write Filter.
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NOTE: 

If you use the Write Filter Enable icon to enable the Write Filter, the restart happens automatically. By default, the 
NetXClean utility purges all but selected profiles on the system when the thin client device starts up or when the user logs 
off. For information on the NetXClean utility, see NetXClean Utility.

Using Roaming Profiles

You can participate in domains by writing roaming profiles to the C drive. The profiles must be limited in size, and it is not retained when the 
thin client device is restarted. For successful downloading and proper functioning, there must be sufficient disk space available for roaming 
profiles. Sometimes, it may be necessary to remove software components to free space for roaming profiles.

Using the Net and Tracert utilities
Net and Tracert utilities are available for administrative use. For example, determining the route took by packets across an IP network.

For more information on these utilities, go to www.microsoft.com.

Managing Users and Groups with User Accounts
To create and manage user accounts and groups, and configure advanced user profile properties, use the User Accounts window. By 
default, a new user is only a member of the Users group and is not locked down. As an administrator, you can select the attributes and 
profile settings for users.

This section provides quick-start guidelines on:

• Creating User Accounts

• Editing User Accounts

• Configuring User Profiles

NOTE: For detailed information on using the User Accounts window, click the Help icon and examples links provided throughout 
the wizards. For example, you can use the Windows Help and Support window to search for items such as user profiles and user 
groups. Obtain links to detailed steps on creating and managing these items.

Creating user accounts
Only administrators can create user accounts locally or remotely through VNC. However, due to local flash or disk space constraints, the 
number of additional users on the thin client device should be kept minimum.

CAUTION: To permanently save the information, ensure that you disable the Unified Write Filter (UWF).

1 Log in as an administrator.

2 Go to Start > Control Panel > User Accounts.

3 On the User Accounts window, click Manage another account.

The Manage Accounts window is displayed.

4 Click Add new user in PC settings.

The PC settings wizard starts. Use this wizard to create a user account.

5 After creating the standard users and administrators, these users will appear in the Manage Accounts window. See Step 3.

Editing user accounts
Open the User Accounts window as described in Managing User Accounts.
To edit the default settings of a standard user or administrator account:

1 On the User Accounts window, click Manage another account.
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The Manage Accounts window is displayed.

2 To change as required, select User.

The Change an Account window is displayed. Now make the desired changes using the links provided.

Configuring user profiles
Open the User Accounts window as described in Managing User Accounts.

CAUTION: 

• By default, all application settings are set to cache to C drive. Dell recommends that you cache to the RAM Disk Z drive as is preset 
in the account profiles to avoid overflowing the Unified Write Filter cache.

• It is recommended that other applications available to new and existing users be configured to prevent writing to the local file 
system because of the limited size of the disk space. It is recommended that care be exercised when changing configuration 
settings of the factory-installed applications.

To configure the default admin and user profiles stored on the thin client:

1 On the User Accounts window, click Configure Advanced User Profile Properties.

The User Profiles dialog box is displayed.

2 Use the command buttons such as Change Type, Delete, and Copy to as described in the Microsoft documentation provided 
throughout the wizards.

Changing the computer name of a thin client
Administrators can change the computer name of a thin client. The computer name information and the Terminal Services Client Access 
License (TSCAL) are preserved regardless of the Unified Write Filter state (enabled or disabled). This maintains the specific computer 
identity information and facilitates the image management of the thin client.
To change the computer name of a thin client device:

1 Log in as an administrator.

2 Go to Start > Control Panel > System.

The System window is displayed.

3 In the Computer name, domain, and workgroup settings section, click Change Settings.

The System Properties dialog box is displayed.

4 Click Change to rename the computer name.

5 In the Computer Name window, type the name for the thin client device in the Computer name field, and click OK.

6 In the Confirmation dialog box, click OK to restart for applying the changes.

7 Click Close, and then click Restart Now to apply the changes.
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System administration
To maintain your thin client device environment, you can perform local and remote system administration tasks. The tasks include:

• Accessing thin client BIOS settings

• Unified Extensible Firmware Interface (UEFI) and secure boot

• Using Wyse Management Suite

• WDM software for remote administration

• Ports and slots

• Using Tight VNC (Sever and Viewer) to shadow a thin client

 

Accessing thin client BIOS settings
The following table provides guidelines to access the BIOS settings on the supported thin client devices:

Table 3. Accessing thin client BIOS settings

Thin clients BIOS settings guidelines

• Wyse 5020 thin client with Win10 IoT (D90Q10)

• Wyse 7020 thin client with Win10 IoT (Z90Q10)

• Wyse 7020 accelerated graphics thin client with Win10 IoT 
(Z90QQ10)

To access the thin client BIOS settings, do the following:

1 During system start-up, press Delete when you see a Wyse 
logo.

The BIOS Setup screen is displayed.

2 When prompted for the password, enter Fireport.

3 Change the required BIOS settings.

4 Save the changes and exit.

• Wyse 5060 thin client

• Wyse 7040 thin client

• Latitude 3480 mobile thin client

• Latitude 5280 mobile thin client

• Latitude 3190 mobile thin client

• Latitude 5490 mobile thin client

To access the thin client BIOS settings, do the following:

1 During system start-up, press F2 when you see a Dell logo.

The BIOS Setup screen is displayed.

2 Change the BIOS settings as required.

3 Save the changes and exit.

Unified Extensible Firmware Interface and secure boot
Unified Extensible Firmware Interface (UEFI) is a standard firmware interface designed to improve software interoperability and address 
limitations of BIOS. UEFI is designed to replace Basic Input Output System (BIOS).

Secure Boot is a feature on UEFI-based clients that help increase the security of a client by preventing unauthorized software from running 
on a client during the boot sequence. It checks whether each software has a valid signature, including the operating system (OS) that is 
loaded during booting.

6
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The thin client device is enabled with UEFI and Secure Boot. Due to this feature, you cannot boot from USB keys if you do not enter the 
BIOS, disable Secure Boot, change the boot mode to Legacy, and enable the Boot from USB option.

Booting from DOS USB key 
The following table provides guidelines to boot from a DOS USB key on the supported thin client devices:

Table 4. Booting from a DOS USB key

Thin clients Guidelines to boot the thin client

• Wyse 5020 thin client with Win10 IoT (D90Q10)

• Wyse 7020 thin client with Win10 IoT (Z90Q10)

• Wyse 7020 accelerated graphics thin client with Win10 IoT 
(Z90QQ10)

To boot the thin client from a DOS USB key, do the following:

1 During system start up, press Delete when you see a Wyse 
logo.

The BIOS Setup screen is displayed.

2 Set the Secure Boot to Disabled.

3 Set the Boot Mode to Legacy.

4 Set the Boot from USB to Enabled.

5 Save the changes and exit.

6 From the pop-up menu, select your USB key, and boot as 
Normal.

• Wyse 5060 thin client

• Wyse 7040 thin client

• Latitude 3480 mobile thin client

• Latitude 5280 mobile thin client

• Latitude 3190 mobile thin client

• Latitude 5490 mobile thin client

To boot the thin client from a DOS USB key, do the following:

1 During system start up, press F2 when you see a Dell logo.

The BIOS Setup screen is displayed.

2 Set the Secure Boot to Disabled.

3 Click Advanced Boot Options, and select Enable Legacy 
Option ROMs.

4 Click Boot Sequence, and set Boot List to Legacy.

5 Click System Configuration > USB Configuration, and select 
Enable USB Boot Support.

6 Save the changes and exit.

7 During system start up, press F12, and select your USB key in 
the boot menu.

Booting from UEFI USB key
The following table provides the guidelines to boot from a UEFI USB key on the supported thin client devices:

Table 5. Booting from a UEFI USB key

Supported thin clients Guidelines to boot the thin client

• Wyse 5020 thin client with Win10 IoT (D90Q10)

• Wyse 7020 thin client with Win10 IoT (Z90Q10)

• Wyse 7020 accelerated graphics thin client with Win10 IoT 
(Z90QQ10)

To boot the thin client from a UEFI USB key, do the following:

1 During system start up, press Delete when you see a Wyse 
logo.

The BIOS Setup screen is displayed.

2 Set the Secure Boot to Disabled.

3 Set the Boot from USB to Enabled.

42 System administration



Supported thin clients Guidelines to boot the thin client

4 Save the changes and exit.

5 From the pop-up menu, select your USB key, and boot as 
Normal.

• Wyse 5060 thin client

• Wyse 7040 thin client

• Latitude 3480 mobile thin client

• Latitude 5280 mobile thin client

• Latitude 3190 mobile thin client

• Latitude 5490 mobile thin client

To boot the thin client from a UEFI USB key, do the following:

1 During system start-up, press F2 when you see a Dell logo.

The BIOS Setup screen is displayed.

2 Set the Secure Boot to Disabled.

3 Click System Configuration > USB Configuration, and select 
the Enable USB Boot Support check box.

4 Save the changes and exit.

5 During system start up, press F12, and select USB key in the 
boot menu.

NOTE: You can boot the Windows 10 IoT Enterprise 
(WIE10) 64–bit devices if the secure boot is set to 
Disabled. However for security purposes, this is not 
recommended.

Creating bootable UEFI USB key 
To create a bootable UEFI USB key, do the following:

1 Obtain an executable UEFI shell.

NOTE: You can download the unsigned reference shell from Sourceforge Download Center.

2 Save the file as bootx64.efi on your client.

3 Format the USB key with FAT32.

4 In the USB key, create the \efi\boot directory.

5 Copy the bootx64.efi file to the \efi\boot directory on the USB key.

The bootable UEFI USB key is created.

Using Dell Wyse Management Suite
Wyse Management Suite is the next generation management solution that lets you centrally configure, monitor, manage, and optimize your 
Dell Wyse thin clients. The new Suite makes it easier to deploy and manage thin clients with high functionality and performance, and ease 
of use. It also offers advanced feature options such as cloud versus on-premises deployment, manage-from-anywhere using a mobile 
application, enhanced security such as BIOS configuration and port lockdown. Other features include device discovery and registration, 
asset and inventory management, configuration management, operating system and applications deployment, real-time commands, 
monitoring, alerts, reporting, and troubleshooting of endpoints.

For more information about Dell Wyse Management Suite, go to www.dell.com/support/manuals.

NOTE: 

Dell Cloud Client Manager (CCM) is re-envisioned as Wyse Management Suite and provides new features, functionalities with major 
product level enhancements to CCM R14. For more information, see Wyse Management Suite Release Notes at www.dell.com/
support/manuals. Existing customers can continue to manage their thin clients as before, and take advantage of the new features 
introduced in this release.
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WDM software for remote administration
WDM software enables you to configure, monitor and manage Dell Wyse endpoint devices.

WDM provides the following important features:

• Remote shadow

• Reboot

• Shutdown

• Boot

• Automatic device check-in support

• Wake-On-LAN

• Change device properties

From a single console, you can easily issue software images, patches, updates and add-ons and manage all aspects of remote cloud clients 
to ensure peak user productivity.

Ports and slots
The thin client device has many ports and slots. For more information on the ports and slots on the thin client device at your workplace, see 
the respective Quick Start Guide at Dell support site.

To provide the services through the ports, install the appropriate software for the thin client device.

NOTE: 

• You can install other services and add-ons that are available from the Dell website for free or for a licensing fee.

• You can configure the thin client device to use Bluetooth enabled peripherals. For more information, see Configuring Bluetooth 
connections.

TightVNC—server and viewer
To configure or reset a thin client device from a remote location, use TightVNC—server and viewer. TightVNC is primarily intended for 
support and troubleshooting purposes.

Install TightVNC locally on the thin client device. After installation, it allows the thin client to be shadowed, operated and monitored from a 
remote device.

TightVNC Server starts automatically as a service upon thin client device restart. The initialization of TightVNC Server can also be 
controlled by using the Services window by this procedure.

To open TightVNC Server window:

1 Log in as an Administrator.

2 Click Start Menu > TightVNC > TightVNC Server.

NOTE: 

• TightVNC Viewer is available from TightVNC website.

• TightVNC is included in WDM software as a component.

• TightVNC Viewer must be installed on a shadowing or remote machine before use.

• If you want to permanently save the state of the service, ensure that you flush the files of the Unified Write Filter during the 
current system session.
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TightVNC—Pre-requisites
Before TightVNC server installation on a remote machine, to access a thin client device you must know the following:

• IP address or valid DNS name of the thin client device to shadow, operate or monitor.

• Primary password of the thin client device to shadow, operate or monitor.

NOTE: 

• To obtain the IP address of the thin client device, move the pointer over the TightVNC icon in the taskbar,

• To configure TightVNC server, the default password is DELL.

Using TightVNC to shadow a thin client 
TightVNC Server starts automatically as a service upon thin client startup. The TightVNC Server service can also be stopped and started 
by using the Services window.

1 Log in as an administrator.

2 Go to Start > Control Panel > Administrative Tools > Services, and then select TightVNC Server.

3 You may also use the TightVNC Server features in Start > TightVNC.

To shadow a thin client from a remote machine:

a On a remote machine on which TightVNC Viewer is installed, open the New Tight VNC Connection dialog box.
b Enter the IP address or valid DNS name of the thin client that is to be shadowed or operated or monitored.
c Click OK.

The VNC Authentication dialog box is displayed.

d Enter the Password of the thin client that is to be shadowed; this is the Primary Password of the thin client that is to be 
shadowed.

e Click OK.

The thin client that is to be shadowed or operated or monitored is displayed for the administrator in a separate window on the remote 
machine. Use the mouse and keyboard on the remote machine to operate the thin client just as you would if you were operating it 
locally.

Configuring TightVNC server properties on the thin 
client 
1 To open the TightVNC Server Configuration (offline) dialog box, go to Start > TightVNC > TightVNC Server — Offline 

Configuration.

The TightVNC Server Configuration (offline) dialog box is displayed.

2 In the Server tab, set the Primary password. Use this password while shadowing the thin client. Default primary password is Wyse.

3 In the Server tab, select the following check boxes:

• Accept incoming connections

• Require VNC authentication

• Enable file transfers

• Hide desktop wallpaper

• Show icon in the notification area

• Serve Java Viewer to web clients

• Use mirror driver if available

• Grab transparent windows

4 Retain the following check boxes blank:

• Block remote input events
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• Block remote input on local activity

• No local input during client sessions

5 In the Main server port box, select or type 5900.

6 In the web access port box, select or type 5800.

7 In the Screen poling cycle box, select or type 1000.

8 Click OK.

NOTE: For security purposes, Dell recommends that the primary password be changed immediately upon receipt of the thin 
client and it is for administrator use only.
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Network architecture and server environment
This section contains information about the network architecture and enterprise server environment needed to provide network and 
session services for your thin client. It includes:

• Understanding how to configure your network services

• Using Dynamic Host Configuration Protocol (DHCP)

• DHCP Options

• Using Domain Name System (DNS)

• About Citrix Studio

• About VMware Horizon View Manager Services

 

Understanding how to configure your network 
services
Network services provided to thin clients can include DHCP, FTP file services, and DNS. You can configure, design, and manage your 
network services depending on the availability in your environment.

You can configure your network services using:

• Dynamic Host Configuration Protocol (DHCP)

• Domain Name System (DNS)

Using Dynamic Host Configuration Protocol
A thin client is initially configured to obtain its IP address and network configurations from a Dynamic Host Configuration Protocol (DHCP) 
server. A DHCP server provides the IP address or DNS name of the FTP server and the FTP root-path location of software in 
Microsoft.msi form to access the IP address and network configurations through the DHCP upgrade process.

DHCP is recommended to configure and upgrade thin clients as it saves time and efforts needed to complete these processes locally on 
multiple thin clients. If a DHCP server is not available, fixed IP addresses can be assigned and it must be entered locally for each device.

A DHCP server can also provide the IP address of the WDM server. For more information, see WDM software for Remote Administration.

7
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DHCP options
The DHCP options listed in the following table are accepted by the thin clients.

Table 6. DHCP options

Option Description Notes

1 Subnet Mask Required

3 Router Optional but recommended. It is not 
required unless the thin client must interact 
with servers on a different subnet.

6 Domain Name Server (DNS) Optional but recommended

12 Hostname Optional

15 Domain Name Optional but recommended

43 Vendor Class Specific Information Optional

50 Requested IP Required

51 Lease Time Required

52 Option Overload Optional

53 DHCP Message Type Required

54 DHCP Server IP Address Recommended

55 Parameter Request List Sent by thin client

57 Maximum DHCP Message Size Optional (always sent by thin client)

58 T1 (renew) Time Required

59 T2 (rebind) Time Required

61 Client identifier Always sent

155 Remote Server IP Address or name Optional

156 Logon User Name used for a connection Optional

157 Domain name used for a connection Optional

158 Logon Password used for a connection Optional

159 Command Line for a connection Optional

160 Working Directory for a connection Optional

163 SNMP Trap server IP Address list Optional

164 SNMP Set Community Optional

165 Remote Desktop Connection startup 
published applications

Optional

168 Name of the server of the virtual port Optional

186 WDM sever IP IP addresses of WDM Server. If tag 194 is 
specified, then defining this tag is not 
necessary.
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Option Description Notes

190 WDM secure port Optional number, word, or two-bytes array. 
Specifies to use HTTPS to communicate 
with WDM instead of HTTP

192 WDM server port Specifies HTTP (non-secure) 
communication with WDM.

194 WDM server FQDN Optional. If this tag is specified, then 
defining tag 186 is not mandatory.

NOTE: For more information on configuring a DHCP server, see www.microsoft.com.

Using Domain Name System
Thin client devices accept valid Domain Name System (DNS) names registered on a DNS server available to the enterprise intranet. The 
thin client device sends a query to DNS server on the network to translate the name into the corresponding IP address. DNS allows hosts 
to be access by their registered DNS names rather than their IP address.

Every Windows DNS server in Windows Server 2000 and later includes Dynamic DNS (DDNS) and every server registers dynamically with 
the DNS server. For DHCP entry of DNS domain and server location information, see Using Dynamic Host Configuration Protocol (DHCP).

About Citrix Studio
Citrix Studio is a software program that enables you to configure and manage your personalized desktops and applications. It provides an 
easy end-user computing experience across all devices and networks while delivering optimal performance, better security, and improved 
personalization.

NOTE: For more information about installing and configuring the Citrix Studio, go to Citrix Website.

Citrix Studio consists of various wizards that allows you to perform the following tasks:

• Publish virtual applications

• Create groups of server or desktop operating systems

• Assign applications and desktops to users

• Grant user access to resources

• Assign and transfer permissions

• Obtain and track Citrix licenses

• Configure StoreFront

All available Virtual Desktop Applications (VDA) are listed in the Studio. From the VDA list, select the application you would like to publish. 
Information displayed in the Studio is received from the Broker Service in the Controller.

About VMware Horizon View Manager
VMware View is an enterprise‐class virtual desktop manager that securely connects authorized users to centralized virtual desktops. It 
provides a complete, end‐to‐end solution that improves control and manageability and provides a familiar desktop experience. Client 
software securely connects users to centralized virtual desktops, back-end physical systems, or terminal servers.

NOTE: For more information, on installing and configuring View Manager, go to VMware Website.

VMware View includes the following key components:

• View Connection Server—A software service that acts as an intermediate for client connections by authenticating and then directing 
incoming remote desktop user requests to the appropriate virtual desktop, physical desktop, or terminal server.
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• View Agent—A software service that is installed on all guest virtual machines, physical systems, or terminal servers. View Manager 
manages this software. The agent provides features such as the Remote Desktop Connection monitoring, virtual printing, remote USB 
support, and single sign-on.

• View Client—It is a locally installed software application that communicates with View Connection Server, to allow users to connect to 
their desktops using Microsoft Remote Desktop Connection.

• View Portal—This component is similar to View Client but provides a View user interface through a web browser. It is supported on 
multiple operating systems and browsers.

• View Administrator—This component provides the View administration through a web browser. View administrators use it to do the 
following:

– Manage configuration settings.

– Manage virtual desktops and entitlements of desktops of the Windows users and groups.

View Administrator also provides an interface to monitor log events and is installed with View Connection Server.

• View Composer—To allow View Manager to rapidly deploy multiple linked clone desktops from a single centralized base image, View 
Composer software service is installed on the Virtual Center server.
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